Welcome, Guest
  • Page:
  • 1
  • 2

TOPIC: Cam table in follow mode

Cam table in follow mode 2 years 2 months ago #2271

  • George
  • George's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 8
  • Karma: 0
M1= motor1, M2 = motor2:

Here is what I did:
I created CAM table in M2 (follower). Also, I created this subroutine:
MF0
SRC(1)
MCE(0)
MCW(1,0)
MFA(0) MFD(0)
MFMUL=1 MFDIV=10 MFR
MCMUL=1 MCDIV=1
MFSLEW(3910800,0) MFSDC(-1,0)
MC
M1 EncA and EncB are connected to M2 A & B.
M1 is commanded to move (G:0) to a specific distance and M2 followed .
For example if M1 to move to 100 M2 should move 345. It worked.
If I set MFMUL=-1 for M2 and the target position zero for M1; G:0.
M1 moves in opposite dir. and M2 does not move.

M2 follows M1 in one direction. I changed MFSDC(-1,k) where k=0,1,2 the same.
However, if I do not use CAM table, M2 follows M1 in both direction without
even setting MFMUL=-1. What is the problem? Thanks.
The administrator has disabled public write access.

Re: Cam table in follow mode 2 years 2 months ago #2272

  • csearcy
  • csearcy's Avatar
  • OFFLINE
  • Moderator
  • Posts: 459
  • Thank you received: 77
  • Karma: 23
Are you doing an MFR after changing MFMUL? It is required for the recalculation.
The administrator has disabled public write access.

Re: Cam table in follow mode 2 years 2 months ago #2273

  • George
  • George's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 8
  • Karma: 0
NO. I will try it. NO motion
Last Edit: 2 years 2 months ago by George.
The administrator has disabled public write access.

Re: Cam table in follow mode 2 years 2 months ago #2274

  • George
  • George's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 8
  • Karma: 0
From the terminal: I did
MFMUL=-1
MFR
M2 did not move.
The administrator has disabled public write access.

Re: Cam table in follow mode 2 years 2 months ago #2275

  • George
  • George's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 8
  • Karma: 0
Not working: Even though I created another subroutine. I removed MF0 and changed MFMUL=-1
and changed the table point and run the subroutine. No effect.
The administrator has disabled public write access.

Re: Cam table in follow mode 2 years 2 months ago #2276

  • csearcy
  • csearcy's Avatar
  • OFFLINE
  • Moderator
  • Posts: 459
  • Thank you received: 77
  • Karma: 23
Do you have the CAN option that allows Combitronic communication between the motors?
The G:0 command will only work over that network. What is the full part number on your motor?

If you don't have the CAN option, you can still do it over RS232, but the commands are different. Let me know what you have and I can probably recommend something else to try.
Last Edit: 2 years 2 months ago by csearcy.
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Moderators: hsummer, csearcy, swalters, mmeyers
Time to create page: 0.558 seconds
Powered by Kunena Forum