Welcome, Guest
Messages posted to this category need to be reviewed by the moderator before it gets posted.

TOPIC: RS-485 Communication problem M-Style motor

RS-485 Communication problem M-Style motor 4 years 7 months ago #1421

  • Daryl N.
  • Daryl N.'s Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 7
  • Thank you received: 1
  • Karma: 0
We are trying to get a single M-Style Smartmotor commanded over a rs-485 network. The motor is a SM23165MT-IP version 5.98.3.61 We can command it using the SMI software with no problem. We are hooked up to an AB compactlogix L32E through a Ethernet IP to Ascii realtime automation gateway. When we send the command "RPA" out from the compactlogix The smartmotor receives the command and acts like it ignores it. We can type the command in the terminal window and the smartmotor responds correctly. Not sure what we are missing any help would be appreciated.

Daryl
The administrator has disabled public write access.

Re: RS-485 Communication problem M-Style motor 4 years 7 months ago #1422

  • csearcy
  • csearcy's Avatar
  • OFFLINE
  • Moderator
  • Posts: 459
  • Thank you received: 77
  • Karma: 23
Hi Daryl,
If you open up the Serial Data Analyzer in SMI2 you can see exactly what is being sent to the motor with the RPA command. If the motor address is 1, it actually sends Hex81 before the RPA. Hex80 is global, Hex81 is Motor1, Hex82 is Motor2, etc.
The administrator has disabled public write access.

Re: RS-485 Communication problem M-Style motor 4 years 7 months ago #1423

  • Daryl N.
  • Daryl N.'s Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 7
  • Thank you received: 1
  • Karma: 0
Wish I could figure out a way to send a snap shot of the Serial data analyzer. This is what I see in the window. Address of the motor is 1

>81 52 50 41 0D |..RPA..

Daryl
The administrator has disabled public write access.

Re: RS-485 Communication problem M-Style motor 4 years 7 months ago #1424

  • csearcy
  • csearcy's Avatar
  • OFFLINE
  • Moderator
  • Posts: 459
  • Thank you received: 77
  • Karma: 23
That's what I expected you would see. So you have to send Hex81 before the RPA and follow it with a carriage return which is Hex0D.
The administrator has disabled public write access.

Re: RS-485 Communication problem M-Style motor 4 years 7 months ago #1425

  • Daryl N.
  • Daryl N.'s Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 7
  • Thank you received: 1
  • Karma: 0
A little confused..... The first characters are Hex81 and the last Set is Hex0D. The command does include those values. Are you saying to follow the Hex81 with a carriage return as well?
The administrator has disabled public write access.

Re: RS-485 Communication problem M-Style motor 4 years 7 months ago #1426

  • csearcy
  • csearcy's Avatar
  • OFFLINE
  • Moderator
  • Posts: 459
  • Thank you received: 77
  • Karma: 23
No... the string coming out of your ASCII converter should look just like what you see in the serial data analyzer.
The administrator has disabled public write access.
Moderators: hsummer, csearcy, swalters, mmeyers
Time to create page: 0.236 seconds
Powered by Kunena Forum