Welcome, Guest
Username Password: Remember me
Messages posted to this category need to be reviewed by the moderator before it gets posted.
  • Page:
  • 1

TOPIC: "Cannot establish a link to Motors!"

"Cannot establish a link to Motors!" 2 years, 10 months ago #1203

Good morning, all. I'm having trouble communicating with an SM34165DT.

I've had this for a couple of months and all has seemed well. Yesterday I revised the program, attempted to download it, and got the message "Cannot establish a link to Motors!"

I've powered down and restarted the motor and PC. I've checked the commnunications cables. I've replaced the serial adapter. I've changed the serial adapter from Com5 to Com4 and back. I've tried the Communication Lock-up Recovery Wizard. Nothing works. I can see the LED blinking on the serial adapter, so at least the PC is communicating _that_ far. I've loaded an old program and tried sending that to the motor. No dice.

I'm at a loss. Nothing I've tried yesterday or today has worked. Murphy's Law must be kicking in -- all was well until the project came under a tight deadline.

Motor: SM34165DT E165881
SMI version: 2,4,3,2
Serial converter: Aten Technologies USB to serial bridge.
Communications settings: COM5, 9600, 8, None, 1, FIFO buffers set to High.

Thank you, in advance, for your help.

Re: "Cannot establish a link to Motors!" 2 years, 10 months ago #1204

  • csearcy
  • Posts: 480
  • Karma: 23
Here's a couple of things to try.
1. Set the FIFO buffers to the lowest setting.
2. Remove the power/com connector from the motor. Jump pin3 to pin4. This will allow you to do an RS232 loopback test. With the jumper in place... go to the COM5 tab in the Terminal Window. Make sure the little check box in the upper left of the window is checked. Type a command that doesn't expect a response... like.. a=123 ...and press Enter. You should see the same command come back because you have transmit tied to receive. If you don't get the command echoed back... use a multimeter to check continuity on all wires.

Re: "Cannot establish a link to Motors!" 2 years, 10 months ago #1205

Thank you for the help. I walked away from the system for a while yesterday morning, and when I came back it had decided to communicate again. I'm not sure what happened or changed, but I'm glad that it did.
The following user(s) said Thank You: csearcy
  • Page:
  • 1
Moderators: hsummer, csearcy
Time to create page: 0.43 seconds