Welcome, Guest
Username Password: Remember me
Messages posted to this category need to be reviewed by the moderator before it gets posted.
  • Page:
  • 1
  • 2

TOPIC: Unable to send "Go"-command?

Unable to send "Go"-command? 2 years, 4 months ago #1500


I just recieved 2 smart motors model SM34165DT, which are supposed to be used on separate applications.

When I built the RS232-RS485 link I connected pins 3, 4 and 5 on the RS485 with pins 2,3 and 5 on the RS232. When using the cable I'm able to recieve information from the motors, although with a red shiny led on the motor. But the motor won't "start". I'm able to "clear flags" (which indicates that the motor is "off"), which results in a flashing green light, until I try to execute a command, after which the led goes back to shine red.

Question: Is pins 1 and 2 on the RS485 supposed to be connected to the RS232? If not, why won't the motors execute the "Go"-command?

I'm in a bit of a hurry, as usual..

Thanks for any help!

Re: Unable to send "Go"-command? 2 years, 4 months ago #1502

  • csearcy
  • Posts: 480
  • Karma: 23
Make sure you have the over travel inputs disabled.

Then try the G command again. Let me know if it works.

Re: Unable to send "Go"-command? 2 years, 4 months ago #1503

It worked all right! Thank you!

Have another problem though. After loading any of the described "test programs" (I have currently loaded the "DMX Packet test example", without errors), I can't get the motor to respond to any of the DMX channels. Been over the instruction a hundred times and can't find any obvious faults.

Can I send the motor DMX commands while having it connected to my computer?

Re: Unable to send "Go"-command? 2 years, 4 months ago #1504

I guess what I realy need is a simple program that admits my smart motors to spinn without the aid of a computer when I raise the channel 1 (or 2, or 3 etc.) fader. A "this demonstrates the basic function"-program. The idea is to test a concept on tour beginning next week.

Re: Unable to send "Go"-command? 2 years, 4 months ago #1512

  • hsummer
  • Posts: 12
  • Karma: 1
Make sure you have DMX wired into the 485 channel and not 232. RS485 is on pins 5 and 6 of the DB-15 connector.
Try the test program that is int he DMX guide with just one motor and use SMI to monitor the variables for data as is listed in the DMX guide to see if sending data works.
And to answer the question about RS232 and SMI running at the same time as DMX, yes, you can do that.

Re: Unable to send "Go"-command? 2 years, 4 months ago #1516

I have now checked the complete signal chain and tested the equipment with a high quality dmx signal, connected to pins 5 and 6 on the 15 pin connector. It doesn't react at all. More over, it seems it doesn't recieve status bit 2 on status word 12.
Have also tried to turn ECHO off since it caused fault messagesn (have only one motor connected in the chain).

My theory is that the motors DMX channel isn't open at all, though the program includes the "OCHN(DMX,1,N,250000,2,8,D)"-command.
  • Page:
  • 1
  • 2
Moderators: hsummer, csearcy
Time to create page: 0.46 seconds