Welcome, Guest
Username Password: Remember me
Messages posted to this category need to be reviewed by the moderator before it gets posted.
  • Page:
  • 1
  • 2

TOPIC: Daisy chain 485 communication Problem

Daisy chain 485 communication Problem 4 years, 3 months ago #639

  • crcrcr
  • OFFLINE
  • Posts: 6
  • Karma: 0
Dear sir

We are using two smart motors (478T)for our research purpose. we have connected two servo motors through RS232 port to computer and used daisy chain connection through RS485 wiring.
It was working fine for a long time with the program mentioned below.
Now i am experiencing a serious problem
After motor-1 moved to the first target position (p=20000) the process is stopping and when we try to communicate to the
motor through SMI it indicates an error like this.

"A response was expected from a motor on the port "Com1",but was not received.Please check the power, connections
and port setting. Also please make sure the motor address is correct. The motor address may be changed by a
user program after the motor is reset or the user program is run."

,I verified the connections. But can't resolve the issue.

Kindly help us to resolve this issue.


Motor-1
SADDR1
ECHO
UCI
UDI
ZS
MP
OCHN(RS4,1,N,9600,1,8,C)
END
C1
MP
IF @P>19600
A=100
V=48760
P=0
G
TWAIT
ELSE
A=100
V=48760
P=20000
G
TWAIT
ENDIF
PRINT1(#130,"GOTO2",#13)
END


Motor-2
SADDR2
ECHO
UCI
UDI
ZS
MP
OCHN(RS4,1,N,9600,1,8,C)
END
C2
MP
IF @P>19880
END
ELSE
r=485
A=100
V=10000
P=r+@P
G
TWAIT
ENDIF
PRINT1(#129,"GOTO1",#13)
END

Re: Daisy chain 485 communication Problem 4 years, 3 months ago #645

  • csearcy
  • OFFLINE
  • Posts: 480
  • Karma: 23
The error response is from the RS232 connection on the motor. It could be due to a USB to RS232 adapter or an intermittant wiring issue. Please contact our tech support at 888-356-0357 if you continue to have problems.

Re: Daisy chain 485 communication Problem 4 years, 3 months ago #648

  • crcrcr
  • OFFLINE
  • Posts: 6
  • Karma: 0
THE PROBLEM I AM NOT ABLE TO SORT OUT. CAN I GET THE FACTORY SETTING
FOT THE MOTOR MODEL NO SV1720D-PLS,
VERSION 4.78T,SERIAL NO EG08269 ,PATENT 5912541 HOW TO GET IT

Re: Daisy chain 485 communication Problem 4 years, 3 months ago #649

  • csearcy
  • OFFLINE
  • Posts: 480
  • Karma: 23
You can send that information to This e-mail address is being protected from spambots. You need JavaScript enabled to view it and they will be able to send you the factory settings file. I cannot post them on the forum.

Re: Daisy chain 485 communication Problem 4 years, 2 months ago #652

  • crcrcr
  • OFFLINE
  • Posts: 6
  • Karma: 0
so far i have not recevied the factory setting in .adb file format.i just want some solution to this problem,with out this i cannot work or carry out my studies.
My Email; This e-mail address is being protected from spambots. You need JavaScript enabled to view it ,

Motor 1

SERVID
MODEL :SV1720D-pls
version :4.78T
serial# :EG08944
Mfg.Date; 11/03/09
Patent : 5912541

Motor 2

SERVID
MODEL :SV1720D-pls
version :4.78T
serial# :EG08269
Mfg.Date; 05/15/09
Patent : 5912541

Re: Daisy chain 485 communication Problem 4 years, 2 months ago #653

  • csearcy
  • OFFLINE
  • Posts: 480
  • Karma: 23
Does the SMI2 software show that you have an ADB error? I haven't been able to find the file for your serial number.
  • Page:
  • 1
  • 2
Moderators: hsummer, csearcy
Time to create page: 0.45 seconds