Welcome, Guest
Username: Password: Remember me
Messages posted to this category need to be reviewed by the moderator before it gets posted.
  • Page:
  • 1

TOPIC: I keep getting junk on my screen while polling with the monitor status window, what's wrong?

I keep getting junk on my screen while polling with the monitor status window, what's wrong? 8 years 3 months ago #17

  • Animatics
  • Animatics's Avatar
  • OFFLINE
  • Posts: 44
  • Thank you received: 1
  • Karma: 0
There could be a print statement in your program. Make sure that ECHO is off. There is a chance that the memory module is corrupt.
The administrator has disabled public write access.

Re: I keep getting junk on my screen while polling with the monitor status window, what's wrong? 6 years 4 months ago #355

What might be a reason to a cutting off part of a PRINT statement?

Simple code shows that:


ZS 'Clear faults
MP 'Set Position Mode

A=1000000
V=1000000
P=2000
G
TWAIT
PRINT("MOTOR IS @ 360.00")

TWAIT
A=10000
V=10000
P=0
G
TWAIT
G
PRINT("MOTOR IS @ 0")
G

END

it shows on the screen:
RUN
MOTOR IS @ 360.00 0

any idea? and how can i print the next line on a new line?

thanks
The administrator has disabled public write access.

Re: I keep getting junk on my screen while polling with the monitor status window, what's wrong? 6 years 4 months ago #356

  • csearcy
  • csearcy's Avatar
  • OFFLINE
  • Posts: 459
  • Thank you received: 77
  • Karma: 23
The Motor View, Monitor, and Chart View don't expect PRINT statements in your program to be sending data while they are polling. You can use the SILENT and TALK commands to enable and disable PRINT statements when needed.

To get a carriage return, add #13 to the PRINT command.
ex. PRINT("MOTOR IS @ 360.00",#13)
The administrator has disabled public write access.
  • Page:
  • 1
Moderators: hsummer, csearcy
Time to create page: 0.274 seconds