Welcome, Guest

TOPIC: Frimware upgrade for old motor

Frimware upgrade for old motor 6 years 8 months ago #457

  • meirmark
  • meirmark's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 3
  • Karma: 0
Hello.
I have a 3 axis machine with 3 SM2320SQ motors.

Where can I get the manual for the motors ?
Can I upgrade the firmware (now is 4.12) ?
I tried to use the motors with the SMNC prog and got en error "Host mode is not supported" can you please help ?

Thanks
Meir Mark.
The administrator has disabled public write access.

Re: Frimware upgrade for old motor 6 years 7 months ago #458

  • csearcy
  • csearcy's Avatar
  • OFFLINE
  • Moderator
  • Posts: 459
  • Thank you received: 77
  • Karma: 23
The manuals for the older motors are located at www.animatics.com/legacy-downloads.html?task=view ...but your particular firmware precedes these manuals.

The 4.12 firmware cannot be upgraded to work with SMNC. You will need newer motors for that.
The administrator has disabled public write access.

Re: Frimware upgrade for old motor 6 years 7 months ago #459

  • meirmark
  • meirmark's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 3
  • Karma: 0
Can you please show a demo program to set the motor to work in Step & Direction mode ?

Thanks
Meir Mark.
The administrator has disabled public write access.

Re: Frimware upgrade for old motor 6 years 7 months ago #460

  • csearcy
  • csearcy's Avatar
  • OFFLINE
  • Moderator
  • Posts: 459
  • Thank you received: 77
  • Karma: 23
Issue the command MS ....and the motor will be ready to receive Step and Direction signals on PortA(Step) and PortB(Direction).
The administrator has disabled public write access.

Re: Frimware upgrade for old motor 6 years 7 months ago #461

  • meirmark
  • meirmark's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 3
  • Karma: 0
I did it but the motor is not responding to the pulses on the step input.
the port is working ,I can see the change on the SMI .
The administrator has disabled public write access.

Re: Frimware upgrade for old motor 6 years 7 months ago #462

  • csearcy
  • csearcy's Avatar
  • OFFLINE
  • Moderator
  • Posts: 459
  • Thank you received: 77
  • Karma: 23
If the motor is in STEP mode, both LED's on the motor should be solid green.
I don't have reference for the version 4.12 firmware, but you may have to issue a "G" command.
The administrator has disabled public write access.
Time to create page: 0.229 seconds
Powered by Kunena Forum