Welcome, Guest
Messages posted to this category need to be reviewed by the moderator before it gets posted.

TOPIC: Rs232 problem comunication

Rs232 problem comunication 6 years 7 months ago #1401

  • bmiguel
  • bmiguel's Avatar
  • Fresh Boarder
  • Posts: 2
  • Karma: 0
Good afternoon,
I'm trying to connect the smart motor SM34165D to pc using RS-232 interface with the smart engine software(SMI). By activating the option "detect usb motors" or "detect motors on rs-232 chain" SMI software does not detect motor and I dont know why it´s happen. The 7W2 Combo D-sub connector cable is cut at one end (was already cut when I received the engine ...) connecting wires A1 and A2 to my source 27vdc - 37A and connecting wires 3,4,5 7W2 Combo D-sub connector rs232 female connector respectively 2,3,5 goo.gl/FDHQft.
I do not have problems of power supply because it is new and the green LED motor blinks when I turn the engine source.

Have tried using rs-232 connector to usb goo.gl/Swk6vm, but the results were the same.

I've been reading the user guide goo.gl/xr4qQe smart engine but without success: (

Any help would be very useful. Good weekend.

Bruno Silva
The administrator has disabled public write access.

Re: Rs232 problem comunication 6 years 7 months ago #1403

  • csearcy
  • csearcy's Avatar
  • Moderator
  • Posts: 464
  • Thank you received: 80
  • Karma: 23
Two things you can try...
1. Do an RS232 loopback test by jumping pin3 to pin4 on the 7W2 connector. In the SMI2 software, click on the Tab in Terminal View to select your RS232 port. Make sure the checkbox to open the port is checked. Type a=123 in the Terminal window. If your USBtoRS232 device is working, you should see a=123 echoed back. This doesn't prove that Rx and Tx are wired correctly, but it gets you close. If the next option doesn't work, try swapping Rx and Tx in your cable wiring.
2. In the SMI2 software, select Communication Lockup Wizard from the communication menu. Follow the directions to remove and re-apply power to the motor. If this is successful, clear your EEPROM and you should be able to connect.
Last Edit: 6 years 7 months ago by csearcy.
The administrator has disabled public write access.
Time to create page: 0.182 seconds
Powered by Kunena Forum