Welcome, Guest
Messages posted to this category need to be reviewed by the moderator before it gets posted.

TOPIC: Smart Motor with Arduino, can't receive reports

Re: Smart Motor with Arduino, can't receive reports 6 years 11 months ago #736

  • csearcy
  • csearcy's Avatar
  • OFFLINE
  • Moderator
  • Posts: 463
  • Thank you received: 79
  • Karma: 23
Real Laptop RS232 ports... usually don't have a problem... but if you have a USBtoRS232 or a 3rd party RS232 USART... Then the operating system comes back in play. See if you can sustain higher baud rates with the SMI2 software first. If it fails... you may need to check wiring and grounding (shielded cables with the shield tied to Single Point Ground is recommended)

When running Windows and SMI...
The following is dependant on what version of Windows you are running...
... I'm running Win7/64bit...
Go to the Device Manager... and look for Ports (COM & LPT)... open that up.
Select your USBtoRS232 device... open that up.
Select the Port Setting Tab...
Select the Advanced Tab...
You should have two sliders for Receive Buffer and Transmit Buffer. Slide those to the Lowest setting.
You can also reset your COM Port Number if needed.
Click OK and close Device Manager out.
Retry communications at the higher Baud Rate. If the communications works at the higher Baud Rate with SMI2 and your Laptop/PC... then you need to check the timing on the Arduino compared to your Laptop/PC.
Last Edit: 6 years 11 months ago by csearcy.
The administrator has disabled public write access.

Re: Smart Motor with Arduino, can't receive reports 6 years 11 months ago #740

I am actually using SoftwareSerial on the Arduino directly with the Smart Motor, and I think that that was my issue. Apparently SoftwareSerial isn't very reliable at high baud rates, or anything over 9600 really. I can get it to work at lower baud rates, such as 4800, and for a short amount of time at 19200, but it only works for a few seconds, and it doesn't seem to work at all at 38400. Or at least not in my application. I tried using the hardware serial port on the Arduino, but it doesn't seem to work correctly. I think it may be because I have it plugged into the Arduino USB port.

Right now I am investigating the possibility of using an alternate serial library called AltSoftSerial that should be faster. (www.pjrc.com/teensy/td_libs_AltSoftSerial.html)

If that doesn't work, then I'm planning on trying either an Arduino Leonardo or Arduino Mega, as they have hardware serial ports that are separate from USB communications.
The administrator has disabled public write access.

Smart Motor with Arduino, can't receive reports 7 months 4 weeks ago #2390

  • BaseMell
  • BaseMell's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 1
  • Karma: 0
Hello..i think you can also reset your COM Port Number if needed.Click OK and close Device Manager out.
Retry communications at the higher Baud Rate. If the communications works at the higher Baud Rate with SMI2 and your Laptop/PC... then you need to check the timing on the Arduino compared to your Laptop/PC.
The administrator has disabled public write access.
Time to create page: 0.185 seconds
Powered by Kunena Forum